Errore di Avast ” Il sottosistema AAVM ha trovato un errore RPC ” ecco cosa fare !

Vi siete trovati con l icona dell antivirus di avast con un cerchietto rosso

avastj.JPG

e cliccando su con il tasto destro sull icona ( a ) cliccando su Controllo di Protezione all avvio

avast1y.JPG

 vi esce l errore ” Il sottosistema AAVM ha trovato un errore RPC “

avasterrorjl4.jpg

non abbiate paura non dovete ne formattare ne reinstallare l antivirus fate cosi :

Start …Programmi ….Strumenti di Amministrazione … Servizi ..

Vi si aprirà una lista di servizi dovete controllare se quelli nella foto sotto risultano attivi in automatico o meno !

avast.JPG
Se uno dei servizi sopra risulta non essere avviato controllare che :
RPC ( Remote Procedure Call ) sia Attivato e in Automatico e poi attivare anche i servizi che non sono attivi presenti nella foto sopra . Il processo RPC ( Remote Procedure Call ) deve essere attivato per primo perchè è da li che parte tutto il sistema , una volta attivato quello potete attivare tutti gli altri che risultano disattivati o in manuale !

 Per avviare un servizio è molto semplice ora ve lo illustro , cliccate due volte sul servizio che dovete abilitare e vi compare la foto sotto : ( Non guardate il fatto che ce scritto Zero Configuration reti senza fili perche questo è solo un esempio )

avast1.JPG
Per abilitare un servizio in automatico e avviarlo dopo prima di tutto cliccare sul pulsante della foto qui sopra Arresta poi dal menu a tendina come in foto selezionate l opzione Automatico e poi cliccate su Avvia .
Una volta abilitati tutti i servizi presi nella foto all inizio di questo articolo andate su Pannello di Controllo …. Installazione Applicazioni e selezionate il programma Avast come se lo doveste disinstallare solo che invece di scegliere l opzione Disinstalla scegliete l opzione Ripara . Attendente il tempo neccessario e vedrete che l antivirus si riattiva da solo !
Siccome non è normale che un antivirus si disattivi in questo modo e abbiamo qualche sospetto , provate a fare gli aggiornamento dell antivirus e del sistema operativo . A questo punto per finire fate una buona scansione con l antivirus per vedere se la causa di questo disguido è proprio un virus o meno !
Una piccola guida di Avast su questo problema la trovate qui
Buon Lavoro e se avete domande in merito chiedete pure senza problemi

 

9 pensieri su “Errore di Avast ” Il sottosistema AAVM ha trovato un errore RPC ” ecco cosa fare !

  1. con windows xp per il percorso è :
    start – impostazioni – pannello di controllo – strumenti di amministrazione- servizi

    Mi piace

  2. sto impazzendo ho un problema sul mio pc (xp)
    sull icona di vast mi è apparso un cerchietto rosso e non riesco piu ad attivare i providersl non riesco a disinstallare , ho seguito anche le vostre procedure ma niente da fare quel cerchietto rosso è sempre li e l avviso di errore di avast persiste (il sottosistema AAVm ha trovato un errore RPC) vi prego aiutatemi

    Mi piace

  3. @Alessandro

    l errore in questione è un errore della versione 4.8 di Avast ti consiglio vivamente di passare alla 5.0 e di non usare key generator per fare aggiornamenti ! con la versione 5.0 non mi risulta che sia mai uscito quel problema !!

    L errore comunque dipende dai servizi che si sono disattivati come spiegato nell articolo

    Mi piace

  4. Ciao Alberto,

    a me il problema è sorto immediatamente dopo l’aggiornamento di avast, ho seguito le procedure che hai indicato ma dopo RIPARA anche a me il problema persiste e mi appare:

    Error processing packages.
    Please use full update.

    Ok vedi log

    Che si sia accorto che aggiorno avasta col key generetor???? Comunque adesso l’ho disinstallato il key generetor e il problema persiste, non mi fa neppure la scansione l’antivirus.

    Attendo notizie, ciao e grazie.

    Mi piace

  5. @alberto
    ti consiglio di passare alla versione 5 di Avast visto che tra alcuni mesi molto probabilmente la 4.8 non sarà piu aggiornata o seguita come assistenza

    Mi piace

  6. ho fatto tutto cio che c’era da fare pero’ quando vado su installazioni aplicazione cliko su AVAST non trovo la parola RIPARA ( c’e’ solo sritto cambia rimuovi.mi spieghi dov’e’la trovo la parola ripara comunque grazie e bravo sei stato molto chiaro nello spiegare fosero tutti cosi ciao fammmi sapere

    Mi piace

  7. Purtroppo non ho presente il sistema Vista come gestisce i servizi , prova a farmi uno screen della pagina dei servizi e me la posti qui nel Blog .

    Io so che su Xp in questa maniera si risolve senza problemi !

    Mi piace

  8. ho fatto tutto come sopra elencato, ma non va!! non riesco a disinstallare ne riparare, avendo vista come posso fare??

    Mi piace

I commenti sono chiusi.